Data Degradation on Bulk Data Delivery Service
Resolved·Partial outage

This incident has been resolved.

Sun, Nov 17, 2024, 09:30 PM
(4 months ago)
·
Affected components
Updates

Resolved

This incident has been resolved.

Sun, Nov 17, 2024, 09:30 PM

Identified

We are experiencing data degradation that is affecting our Bulk Data delivery service. Our team is actively working on resolving the issue and restoring full functionality. We will provide updates as we make progress.

Wed, Nov 13, 2024, 04:07 PM(4 days earlier)
Powered by