Resolved
All IP addresses returned through the API should be within public IP ranges.
Identified
We have identified how private IPs are making their way through to our API responses. We are working on filtering these out at multiple layers to ensure private IPs are not published through GreyNoise API calls.
Investigating
Some GreyNoise API responses are including private IP addresses alongside public IP addresses. The API should not return any private IP addresses. We are working to resolve this issue by removing all private IPs from our API responses.