Resolved
This incident has been resolved.
Monitoring
Performance is improving, and we are continuing to monitor.
Identified
Our data pipeline is currently suffering degraded performance. This will cause increased latency for events to trigger updates - though visualizer and API performance is unaffected, the data they return will be slower to update.