Delayed Data Processing

Incident Report for GreyNoise Enterprise

Resolved

Processing is complete and normal operations have resumed.
Posted Mar 29, 2025 - 06:11 EDT

Update

We've made the required changes to the pipeline and are now in the processing of burning through the backlog. At our current pace we believe all processing will be complete later this evening. Data is starting to flow into the Visualizer and API again, and bulk data files are being generated for yesterday.

We believe no further action is required as the backlog is reduced, but we'll continue to monitor in the interim.
Posted Mar 28, 2025 - 15:27 EDT

Monitoring

Our system is processing through the backlog of data. We expect to catch up to current by some time tomorrow, and we are considering options to accelerate the recovery.
Posted Mar 27, 2025 - 21:57 EDT

Identified

Abnormally high amounts of Internet traffic have resulted in data processing delays. We are currently adjusting the data pipeline to start burning down the backlog of data.
Posted Mar 27, 2025 - 09:24 EDT
This incident affected: GreyNoise (GreyNoise Visualizer, GreyNoise API, GreyNoise Bulk Data Feed).