Resolved
Trends is now fully working as expected.
Monitoring
The issue is largely mitigated, though a subset of tag trends pages may have issues loading tag timelines. We are continuing to monitor and will update accordingly.
Identified
The Trends feature has a partial outage - a root cause has been identified and a fix is being implemented.